Temporary rollback of 3.65.3 update
Resolved
Apr 14, 2026 at 5:39am UTC
The fix is live and the update is released again.
Thanks for your patience.
Affected services
Updated
Apr 14, 2026 at 5:23am UTC
The fix has passed QA and will be released shortly.
Affected services
Updated
Apr 14, 2026 at 4:28am UTC
We have identified the issue and a fix has been created. It is currently being expedited through our QA process. If all looks good there, it will be released along with the full update.
In the mean time, the service will continue to operate as before.
The team thanks you for your patience.
Affected services
Created
Apr 14, 2026 at 1:00am UTC
Today we released the 3.65.3 update.
During post release monitoring, we noticed some unexpected load on the database infrastructure not seen during QA. The unexpected load coincided with the release of the update.
Due to this, the team made the decision to rollback to the previous version (3.65.2) temporarily to ensure continuity of the service.
We're going to diagnose why the extra load occurred and fix it. Once solved, we'll re-release the 3.65.3 update.
We'll provide updates here as we know more.
Affected services